Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

SWFUploadField Error #2044: Unhandled IOErrorEvent

Go to End

2 Posts   2888 Views


Forum Moderator, 53 Posts

17 June 2010 at 11:49am

I have successfully installed DataObjectManager and SWFUploadField modules on my local machine, using them for a basic image gallery. I upload the files via ftp to the server, the SWFUpload still works for me on my local machine when uploading images using the CMS on the server.

My colleagues get the flash error:
Error #2044: Unhandled IOErrorEvent

Then a js alert box with:
An error occured in the upload. Try again later.

I have the same version of flash, browser etc. I think a file path or bad upload URL is to blame and that my machine is perhaps using some files from the local harddrive to successfully complete the upload? Not sure what config changes I need to make or anything, when I look at var_dump(SWFUploadConfig::DumpConfiguration()); all the paths seem correct.

Also, what file does this URL point to?



Forum Moderator, 53 Posts

23 June 2010 at 10:59am

Update: This one took a lot of debugging.

I think the situation was on my Ubuntu machine I had flash version 10.1 r53 installed, but NOT the debug version. Other Windows machines with the same version of flash may have had the debug version installed. I could upload files from my Ubuntu machine, the Windows machines would get a js popup with an error like:
An Error occurred in the Upload. Try again later.

Also a flash related error like:
Error #2044: Unhandled IO Error Event. Error #2038 File I/O Error.

This was being triggered by an HTTP ERROR, the server handing back a status code of 406 "Not Acceptable"
SWF DEBUG: Event: uploadError: HTTP ERROR : File ID: SWFUpload_0_0. HTTP Status: 406.

The solution for us was this one line in the .htaccess file to turn OFF mod_security:
SecFilterEngine Off

HTH someone.