Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

ImageGalleryPage - Error Saving Content

Go to End

56 Posts   12759 Views


Community Member, 4 Posts

7 October 2010 at 1:10am

I'm having the same problem described here and posted it a few days ago.
I'm quite sure it is a permissions problem, as I can't upload files or create albums until i manually recreated the image-gallery subfolders structure (/pagename, /pagename/_resampled, /pagename/Default-Album and /pagename/Default-Album/_resampled) with my own shell account.

Are you using a earlier version that doesn't have these problems, as I might think about downgrading the system so creating albums and uploading images works?


Community Member, 4 Posts

8 October 2010 at 3:20am

The strange thing is that the ImageGalleryPage folder gets created in assets/image-gallery with www-data as owner, but the script fails when it tries to create the Default-Album folder in it (with, as far as I can see) the same owner.

This is the error i recieve:

Error: Uncaught Exception: Cannot move /var/www/vhosts/mysite/httpdocs/assets/image-gallery/New-ProjectPage-2/ to /var/www/vhosts/mysite/httpdocs/assets/image-gallery/New-ProjectPage/
At line 409 in /var/www/vhosts/mysite/httpdocs/sapphire/filesystem/File.php

There's no New-ProjectPage-2 folder, nor a New-ProjectPage folder.
But there is a new-projectpage folder (lower case)


Community Member, 109 Posts

12 October 2010 at 11:31pm

Edited: 12/10/2010 11:34pm

Ok, me too now.

I am running SS v2.4.0 and already have "modules-dataobject_manager-r395" and "modules-swfupload-r375" running.

I just installed the "modules-image_gallery-r493" image gallery. Then ran dev/build.

When I create a new ImageGalleryPage, the new node appears in the menu tree, but on the main part of the screen all that prints is, "Fatal error: Class 'ImageUploadField' not found in [myPath]\SilverStripe\image_gallery\code\ImageGalleryAlbum.php on line 27".

What do I do?

(PS. One thing I did notice is that, on this page,, you mention that the image directories that get created will be called, ".../MyImageGalleryPage", whereas the directories that actually get created are called, ".../NewImageGalleryPage". Might this be significant?)



Community Member, 109 Posts

13 October 2010 at 11:33pm

...and the answer is.... (boom tish!)

Install uploadify.

Now all works fine. At least it does for me.

Perhaps this should be mentioned in the Image_Gallery installation instructions?


wilhelm oder wil er nicht

Community Member, 16 Posts

4 November 2010 at 2:56am

@CHD: Subdomain. Shouldn't make a difference.
Btw, problem is solved now: it really was a permission thing. I needed to make a few more attempts with changing permissions, don't know why it didn't accept the changes first, now it works. That's it! Hooray.


Community Member, 3 Posts

4 November 2010 at 5:13am

If you don't mind me asking, what did you set for permissions to correct the issue?


Community Member, 1 Post

15 December 2010 at 5:06am

I think I've found solution.

The problem was with filesystem out of sync, but when trying to sync I got "There was an error looking for new files". So I've made it by hand removing all orphaned records in File table (the easiest way is to backup DB and assets filesystem, remove all files and folders from assets and remove almost all files from File table) . Now everything works fine (I'm wondering for how long).

Mr V Dot

Community Member, 8 Posts

8 January 2011 at 2:42pm

Edited: 08/01/2011 2:48pm

Just as an update to people still having an issue with this, changing the permissions on the 'image-gallery' folder in assets to 777 appears to solve the problem (mine was at 755, like the rest of assets). Not sure why yet, I'm still working on figuring out what the lowest permission level that works it, will update once I know.