Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

SWFUpload stuck on Permission:check()


Go to End


5 Posts   1254 Views

Avatar
k0m0r

Community Member, 39 Posts

1 December 2010 at 6:15am

Edited: 01/12/2010 6:16am

Hi.
I'm using SS 2.4.3, DOM r521 and SWFUpload r401.
When I'm trying to use ImageDataObjectManager, the SWFUploadField is stuck on 'Processing...'
Debugging shows up that Permission::check("CMS_ACCESS_CMSMain") returns false, although I have full administrative rights - so FileDataObjectManager::handleswfupload() returns null.
What am I missing here?
Thx for help.

Avatar
UncleCheese

Forum Moderator, 4102 Posts

1 December 2010 at 6:32am

Switch to Uploadify. http://www.leftandmain.com/silverstripe-modules/2010/08/26/uploadify/

--------------------
SilverStripe tips, tutorials, screencasts and more: http://www.leftandmain.com

Avatar
k0m0r

Community Member, 39 Posts

1 December 2010 at 10:44pm

Thx Uncle Cheese!
It works and it's really great, far more intuitive than SWFUpload.

Avatar
Blackdog

Community Member, 156 Posts

2 December 2010 at 3:39pm

Anyone having issues with Uploadify when using Safari or Firefox on the Mac ?

I am getting clients reporting a SQL select error.

Avatar
UncleCheese

Forum Moderator, 4102 Posts

2 December 2010 at 4:10pm

A database error wouldn't have anything to do with your OS. I would look at your code.

---------------
Silverstripe tips, tutorials, screencasts, and more. http://www.leftandmain.com