Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

Uploadify HTTP Error

Go to End

80 Posts   30508 Views


Forum Moderator, 4102 Posts

5 March 2011 at 8:21am

It only applies to frontend forms..

if you have a form like this:

public function MyFormWithUploader() {
return new Form(
// etc..


You need to make sure that function is an allowed action..

static $allowed_actions = array (


Community Member, 30 Posts

5 March 2011 at 8:29am

OK, thanks for that UncleCheese. I was thinking it applied to the CMS Files & Images section too.

Ryan M.

Community Member, 309 Posts

6 March 2011 at 2:37pm

UncleCheese, yeah it was just a front-end form. Nothing was amiss in the CMS.

Terry Apodaca

Community Member, 112 Posts

18 April 2011 at 2:51pm

Edited: 18/04/2011 3:07pm

I don't want to make a new thread on hopefully UncleCheese and/or someone that can help me will see this.

I have this HTTP Error happening to me now, and it took me a while to troubleshoot it, tried everything mentioned in this thread, so I eventually downloaded Charles trial. I have the latest versions of SS, DOM, Uploadify (and I even left the SWFUpload module even though I shouldn't need it, but if I can't fix Uploadify I will have to fall back to using it).

So, my Response is: HTTP/1.1 404 Not Found (I guess when looking for the uploader?

the is the resource it's looking for and can't find:

This domain is a subdomain so I don't know if that's the problem? Does Uploadify have problems if they are installed on a subdomain? I have looked and looked, but haven't found much that isn't already in this thread. This is also outside of the DOM because I am not using it for this image this has to be specific to just Uploadify Module.

Any help would be greatly appreciated.

Here's the code:

Setting up my image (just one for the page).

static $has_one = array(
    'Logo' => 'Image'

Adding it to the CMS using Uploadify

$fields->addFieldToTab("Root.Content.Image", new ImageUploadField('Logo', 'Logo'));

Seems simple enough...just that uploadify gives me the 404 Not Found.

Not sure if this will help, but looked in the accesslogs so I know this is related:

/admin/EditForm/field/Logo/upload HTTP/1.1" 404 2749 "-" "Shockwave Flash"

Terry Apodaca

Community Member, 112 Posts

18 April 2011 at 3:14pm

Response from Charles:

HTTP/1.1 404 Not Found
Date: Mon, 18 Apr 2011 03:13:56 GMT
Server: Apache/2.0.63 (Unix) mod_ssl/2.0.63 OpenSSL/0.9.8e-fips-rhel5 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/ PHP/5.3.4
X-Powered-By: PHP/5.3.4
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-cache, max-age=0, must-revalidate
Pragma: no-cache
Set-Cookie: bypassStaticCache=deleted; expires=Sun, 18-Apr-2010 03:13:56 GMT; path=/; httponly
Set-Cookie: bypassStaticCache=deleted; expires=Sun, 18-Apr-2010 03:13:56 GMT; path=/; httponly
Last-Modified: Tue, 08 Feb 2011 04:17:06 GMT
Vary: Accept-Encoding
Content-Length: 2749
Content-Type: text/html; charset="utf-8"


Community Member, 70 Posts

24 April 2011 at 7:54pm

FYI another angle to check is the version of Flash. The underlying jquery widget uploadify uses Flash, and breaks with some versions. I've just run into a situation where the upload was working (on Ubuntu) and is now failing after an security update. However the same file uploading to the same server is working on my Macintosh which has not been updated. As such I guess add 'Version of Flash' the checklist of why uploadify is not working

Terry Apodaca

Community Member, 112 Posts

30 April 2011 at 4:29am

Well, after tons of research, and after uninstalling everything on this machine that had to do with Flash or Shockwave...letting Uploadify prompt me to download the versions it wanted/needed...I still got this error. I have no idea why. This leads me to believe it's not a flash (version) issue.

I can load this site to my machine running XAMPP and Uploadify works just fine.

I guess I am relegated to the fact that the Host might be running too stiff. I do know they are running mod_security2 (not mod_security) so I can't turn it off in the .htaccess file. I have asked the client/host to see if they can slim down the security a little to allow Flash to upload/communicate with the server but they either won't do it or are taking WA Y too long to respond.

Any other ideas?


Community Member, 79 Posts

30 April 2011 at 9:13am

I don't know if it is that simple :( I have my sites all on the same dedicated server. Uploadify does not work on 2 sites, but works on the other ones... I gave up trying to work it out. Maybe I'll go back and take another looking taking into consideration everything else others have tried to fix it.

Thanks for the persistence everyone.