Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

Uploadify HTTP Error

Go to End

80 Posts   30598 Views


Community Member, 70 Posts

9 June 2011 at 2:14pm

I ran into the HTTP Error on a production machine and could not resolve it, even by moving the phpsessions to a different directory as detailed here - Hard to debug when you dont speak the same language as the sysadmin, and cant see the error/access logs :(

So I took a different approach and decided to change uploadify to use HTML5 upload instead. It appears to be working, though is lacking a few things:

1) No error reporting
2) No upload cancel
3) I've only tested it in Google Chrome
4) Progress meter is text (e.g. 30%) instead of a progress bar
5) Some of the events still rely on the existence in the DOM of the flash uploadify elements, which I've hidden visually

Code is available at

Please consider this very alpha software, as it was a bit of a rush job :)




Forum Moderator, 4102 Posts

9 June 2011 at 3:52pm

UploadifyField::disable_authentication() is the best solution to this problem.


Community Member, 33 Posts

10 June 2011 at 8:49am

Hey guys, tuning in to mention that I'm getting this same HTTP error on any file I try and add with uploadify.

^ Is that line added to the _config.php in /mysite? The website doesn't load at all for me if I add this line.


Forum Moderator, 4102 Posts

11 June 2011 at 3:33am

Yes, it goes in your config. If you're getting a white screen of death, you need to crank up your error reporting to find out what the error is.

SilverStripe tips, tutorials, screencasts and more:


Community Member, 42 Posts

20 June 2011 at 1:12am

Edited: 20/06/2011 1:23am

This is what I get with the "UploadifyField::disable_authentication() "

Fatal error: Call to undefined method UploadifyField::disable_authentication() in /homez.443/mysiteid/www/mysite/_config.php on line 35.

(Also disabled magic quotes and mod security, and swfupload doesn't work either)

Edit : Would there be a way to use ImageDOM without uploadify ? I don't care if I have to upload file by file. It would be nice while we all search how to get rid of the HTTP Error.


Forum Moderator, 4102 Posts

20 June 2011 at 4:13am

If the method doesn't exist then you're running an old version. Make sure you update to the latest rev.

Terry Apodaca

Community Member, 112 Posts

21 June 2011 at 3:08am

@VRoxane I still get the same HTTP Error on only one server now. Download the latest code and see if that will help some of your issues. After I upgraded, used the UploadifyField::disable_authentication() in the config file...all my sites (except one) were fixed.

Another thing to think this will most likely be no issue once 3.0 comes out. Keep that in mind as well.

Let me know if upgrading helped you...and if not then I will try to help as much as I can.


Community Member, 42 Posts

21 June 2011 at 7:40pm

I'll try that on my own website this week.

Does "UploadifyField::disable_authentication()" go in the mysite/_config or in the uploadify/_config ?

I really think the problem comes from the hosting... but I don't know anything about that... Hope 3.0 will do the trick :)

And btw, swfupload gets stuck @ 100% upload as well : /

Thank you both for your help, hope I'll get rid of the HTTP Error soon !!! :) MERCI MERCI MERCI :)