Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

DataObjectManager and Tabset breaks wysiwyg?

Go to End

3 Posts   1149 Views


Forum Moderator, 1307 Posts

27 January 2011 at 5:58am

Edited: 27/01/2011 6:03am

Hi Uncle Cheese and all others,

I've tried to use a tabstrip in the DataObjectManager popup, and all seemed to go well, but then I found that the SimpleTinyMCEField (and other wysiwys) was no longer loading properly. I get a couple of '$ is not a function' errors in the following locations:

.../sapphire/thirdparty/tabstrip/tabstrip.js - line 104
.../sapphire/thirdparty/prototype/prototype.js - line 1845

So this is likely some conflict between prototype and jquery? If a solution exists for this problem, I'm sorry I missed it... This is what I'm doing (simplified):

	function getCMSFields() {

		$fields = new FieldSet();

			new TabSet("Root",
				new Tab('MyTab', 'SomeTab'))

		$fields->addFieldsToTab('Root.MyTab', array(
			$content = new SimpleTinyMCEField(
				$name = 'Content',
				$title = 'Some wysiwig content'
		return $fields;

Any ideas what to block, strip, change or..?


Forum Moderator, 4102 Posts

27 January 2011 at 6:15am

You can't use those CMS tabs in a popup. You can use the tabset I created for DOM, though.. See this thread :


Forum Moderator, 1307 Posts

27 January 2011 at 6:57am

So oops - I did miss it :-(

Thanks for your speedy reaction!