Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba


Go to End

7 Posts   1290 Views


Community Member, 211 Posts

18 March 2011 at 3:35am

Hello evryone

I have ss 2.4.5 installed (fresh install) and tried to install the famous image galery module
I have downloaded the files from GITHUB and named them :


It seems to go ok but when I create a NewImagGalery page nothing happens then when I refresh site tree the page is there but if I try to create albums / photos etc I get weird pages and not the usual clean upload page.
Also if I try to save the page I get an error

Does someone have an idea ?



Community Member, 107 Posts

18 March 2011 at 4:27am

This seems to be a big issue with Image Gallery for the last couple of releases. I had this problem with the GITHUB version and the download version from LeftandMain. It actually is messign up the database.

So be careful with this module until there is a fix.



Community Member, 211 Posts

18 March 2011 at 4:31am


Thanks for you answer

I'm quite worried now because I have another site that is using image gallery



Community Member, 107 Posts

18 March 2011 at 2:53pm

OK, seems like the problem I am having is with IE8. When I do everything in Firefox, it works like a charm.

Has anybody else had problems with Image Gallery with IE8?


Community Member, 3 Posts

26 March 2011 at 1:36am

Edited: 26/03/2011 1:54am

Any news in this matter?

I experience the same problem as servalman, but the interface returned some what after renaming DataObjectManager to dataobject_manager

I am running SS 2.4.5 with:

unclecheese-DataObjectManager-8808fda renamed to "dataobject_manager"
unclecheese-ImageGallery-dc4c750 renamed to "image_gallery"
unclecheese-Uploadify-e94f3c0 renamed to "uploadify"

from Github.

From a fresh install i can create a ImageGalleryPage and add a new gallery and images (only error i see is the "detach" and "delete permanently" buttons in the file upload dialog are colored boxes). At this point the page can successfully be saved.

When trying to change a ordinary "Page" behavior into a "ImageGalleryPage" behavior I get the "error saving content".


Community Member, 7 Posts

27 March 2011 at 5:04pm

I seem to have had some luck with Image Gallery. Here is what I did. Please keep in mind when I write this, I am not a developer, just a minor tinkerer.

Clean install of 2.4.5
Loaded the DataObjectManager Module
Loaded Uploadify
Ran dev/build
loaded the image gallery module
ran dev/build

At this point I had countless probelms, including having the Upload button hidden behind a browse input.

Found a thread about earlier versions of 2.4 and updated with the following patches:

Still having problems, browsing the forum, found something I thought to be a longshot, but it is Renamed folders for each module to be:


And at least for now, it is working. Still testing and will update if I run across any new bugs. I hope this helps!


Community Member, 219 Posts

27 May 2011 at 2:02am

im having a mare with the latest version of image_gallery and ss 2.4.5
it all works fine locally, but as soon as i upload i have problems.

clicking "create image gallery page" does nothing. (emails an error to me saying: Error: Uncaught Exception: Cannot move /var/www/vhosts/ to /var/www/vhosts/
At line 422 in /var/www/vhosts/ )
if i refresh, the page appears, but if i try and upload an image it throws up a server error. and emails me a very similar error message to the one above.

looks like permission issues with image_gallery creating directories?
but my whole assets directory is 777.
AND ive even tried manually creating the directories myself and giving them all 777 but it still fails.

any help?!