Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

Uploaded images showing "file" icon not Thumbnail

Go to End

6 Posts   1609 Views


Community Member, 13 Posts

7 April 2011 at 7:51pm

Hi I have been having some problems with the image gallery when i upload an image in the admin menu rather than showing a thumbnail for the files it just shows a black file icon and does not display anything at all on the live site

I was running 2.3.3 and then updated to 2.4.5 also downloading the latest version from git hub however the error is still persisting.

The files have been uploaded into the assets folder via filezilla, rather than using the upload as that was not working on the clients computer only. ( i have also updated the uploadify version to the current one).

Any suggestions or help would be greatly appreciated


Community Member, 110 Posts

16 April 2011 at 2:45am

Edited: 16/04/2011 2:54am

This sounds like a problem that I had a while ago: uploading an image resulted in a "blank page" icon, and the file was always called "new image" (I think, from memory).

It turned out to be a permissions issue on the "assets" folder and some of the other folders within. I changed the permissions for those folders to 777 and it's been OK since.

Hope this helps you.


Community Member, 4 Posts

2 November 2011 at 2:17pm

Hi, I am getting the same issue as musicaldustbin. Did you solve the problem?


Community Member, 25 Posts

2 November 2011 at 5:16pm

I am getting the same error also. But I have gone and changed the permissions, and reuploaded and installed the modules. all with no luck.

Any one have an ideas?

thanks in advance..


Community Member, 110 Posts

2 November 2011 at 10:21pm

Changing the permissions worked for me. Are you able to upload the images using SilverStripe rather than Filezilla?


Community Member, 4 Posts

3 November 2011 at 11:51am

I can't upload images using filezilla. I am still working on localhost. I can move files into the gallery page using the assets folder, but they display as blank file icons.

How do you change permission to 777?