Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

Fatal error: Class 'TranslatableObject' not found in /var/www/awattgarde-test/mysite/_config.php on line 103

Go to End



Community Member, 1 Post

21 July 2011 at 8:06pm

Running the following update script on a linux server: sudo -u www-data sh /var/www/awattgarde-test/sapphire/sake dev/build

Gives: Fatal error: Class 'TranslatableObject' not found in /var/www/awattgarde-test/mysite/_config.php on line 103
However, dev/build through the browser works.

On the config.php file, some extensions were added:


Object::add_extension('ApplianceData', 'TranslatableObject');
Object::add_extension('Quiz', 'TranslatableObject');
Object::add_extension('QuizOption', 'TranslatableObject');
Object::add_extension('SavingTip', 'TranslatableObject');

Adding another extension also threw the same error. For example, after creating a class which will be an extension and then adding the extension on the _config.php file, then running the /dev/build script returned the same error: 'Class not found.'

The problem was curiously solved by commenting the recently ::add_extension() in the _config.php file, running the /dev/build script, and then adding (uncommenting) the extension in the _config.php file and running /dev/build again. It seems like it's necessary to build the class that will be an extension and afterwards build the extension...

However it makes things a bit complicated... Is this a known bug ? Or is there something wrong in the procedure?