Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

trouble getting colorbox working


Go to End


2 Posts   1273 Views

Avatar
voodoochile

Community Member, 52 Posts

28 July 2011 at 9:48pm

Hi All

I'm needing a little help please.
Recently i have been trying to get my understanding and skills in silverstripe improved so i set myself a project as the best way to learn is to do. the project is to create a module that is based on the dataobjects as pages - part 2 create a product catalouge from www.ssbits.com. essentally i have added extra functionality this includes adding some custom images to the product detail. i wanted the content editor to be able to add extra images to the product and the end user to be able to view the images in a similar fashion to the image gallery. in order to acheive this i was using the example from the Silverstripe 2.4 - modules extension, themes, and widgets book in particular the intro page and image gallery chapter 7.
anyway this has sofar been largley succesfull and the backend works, i can add images give them a title etc on the front end the images display everything works until i click an image and then it just shoots to a resized image no colorbox?.
so far i have discoverd that ...

1. the path i have defined in config.php does not seem to work so the colorbox js and css files do not load
2. if i place the full path in the requirements they load into the page but colorbox does not work.

so here i am .... stuck i am unsure if i have everything setup properly although everything works except the colorbox there are no errors i am using SS 2.4.5 and have tested the Gallery module from the book in the same site and it works so the base setup is ok it's something i have or havent done.

sorry to ramble on but i hope the background is useful. as for code i can post or provide a link to download the whole module, (while it is still in early stages it will install and function but i have alot more i want to add and lots to tidy and finish).

Avatar
voodoochile

Community Member, 52 Posts

29 July 2011 at 8:36am

Edited: 29/07/2011 8:37am