Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

Data Object Manager + SS 2.3.2 Image&Files Tab problem


Go to End


19 Posts   5215 Views

Avatar
mschiefmaker

Community Member, 187 Posts

29 September 2009 at 7:19am

Yup it seems fine now. Will see if I can recreate. In the menatime I am now getting an error message when I access the Add Files to window

[Warning] file_get_contents(/home/anzata/public_html/swfupload/javascript/swfupload_vars.js) [function.file-get-contents]: failed to open stream: No such file or directory
GET /~anzata/admin/assets/EditForm/field/Files/upload

Line 472 in /home/anzata/public_html/sapphire/core/Requirements.php
Source

463
464 }
465
466 /**
467 * Load the given javascript template with the page.
468 * @param file The template file to load.
469 * @param vars The array of variables to load. These variables are loaded via string search & replace.
470 */
471 function javascriptTemplate($file, $vars, $uniquenessID = null) {
472 $script = file_get_contents(Director::getAbsFile($file));
473 foreach($vars as $k => $v) {
474 $search[] = '$' . $k;
475 $replace[] = str_replace("\\'","'", Convert::raw2js($v));
476 }
477 $script = str_replace($search, $replace, $script);
478 $this->customScript($script, $uniquenessID);

Trace

* file_get_contents(/home/anzata/public_html/swfupload/javascript/swfupload_vars.js)
Line 472 of Requirements.php
* Requirements_Backend->javascriptTemplate(swfupload/javascript/swfupload_vars.js,Array,)
Line 133 of Requirements.php
* Requirements::javascriptTemplate(swfupload/javascript/swfupload_vars.js,Array)
Line 156 of SWFUploadConfig.php
* SWFUploadConfig::Bootstrap()
Line 21 of SWFUploadField.php
* SWFUploadField->__construct(UploadForm,Upload,,Array)
Line 256 of FileDataObjectManager.php
* FileDataObjectManager->getUploadFields()
Line 293 of FileDataObjectManager.php
* FileDataObjectManager->UploadForm()
Line 218 of FileDataObjectManager.php
* FileDataObjectManager->upload(HTTPRequest)
Line 129 of RequestHandler.php
* RequestHandler->handleRequest(HTTPRequest)
Line 143 of RequestHandler.php
* RequestHandler->handleRequest(HTTPRequest)
Line 143 of RequestHandler.php
* RequestHandler->handleRequest(HTTPRequest)
Line 122 of Controller.php
* Controller->handleRequest(HTTPRequest)
Line 277 of Director.php
* Director::handleRequest(HTTPRequest,Session)
Line 121 of Director.php
* Director::direct(/admin/assets/EditForm/field/Files/upload)
Line 118 of main.php

The only thing I changes since I accessed it yesterday is that I ftped some files into the assets folder.

Cheers

MM

Avatar
mschiefmaker

Community Member, 187 Posts

29 September 2009 at 7:23am

Hey Uncle Cheese,

Just tried but I can't replicate the issue on the demo. It all works fine there, the button displays and I can access my file system. If its a files issue, any suggestion on what I might need to reload?

Thanks

MM

Avatar
UncleCheese

Forum Moderator, 4102 Posts

29 September 2009 at 7:47am

Do you not have the swfupload module installed? Have you checked your server to see that the swfupload_vars.js file exists?

Avatar
mschiefmaker

Community Member, 187 Posts

29 September 2009 at 7:56am

Ignore the previous error message. The server wasn't working properly, have restarted and I am back to getting a window without an upload button. Yes, I swfupload installed.

Cheers

MM

Avatar
UncleCheese

Forum Moderator, 4102 Posts

29 September 2009 at 8:16am

Any Javascript errors? Is there a public link I can test?

Avatar
mschiefmaker

Community Member, 187 Posts

29 September 2009 at 11:09am

go to http://kiwiwebhost.intron.net.nz/~anzata/admin

Username: test@cb3d.co.nz
Password: test

Bingo on the javascript error. I am getting

jQuery is not defined
dataobjectmanager_popup.js?m=1253656817()dataobje...253656817 (line 8)
[Break on this error] })(jQuery);

jQuery is not defined
filedataobjectmanager_popup.js?m=1253656819()filedata...253656819 (line 35)
[Break on this error] })(jQuery);\n

but I am not sure how to fix this?

Thanks

MM

Avatar
UncleCheese

Forum Moderator, 4102 Posts

29 September 2009 at 11:48am

Make sure you're on the latest version of DOM (r287). The jQuery dependencies have been going through a lot of changes lately.

Avatar
mschiefmaker

Community Member, 187 Posts

29 September 2009 at 1:21pm

Am now running the latest version of DOM and that seems to have got rid of the javascript errors but still no button.