Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, Ed, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba

Working on e-commerce for SS 2.4

Go to End

121 Posts   19258 Views


Community Member, 254 Posts

15 July 2010 at 11:15am

@ mattconfusion
Not sure but don't you have to $page1->Write(); Maybe WriteToStage does the same thing, I'm not too familiar with it.


Community Member, 48 Posts

16 July 2010 at 10:25pm

thanks bambi, it works, but neede also to give the requiredDefaultRecords name to the function.
Anyway, i wonder if someone has already noticed it, there is some weird behaviour in ProductGroups especially when you are using store "ModelAdmin". You create a product but assigning it to a category it just won't work, or well, that's what happened to me. More, there are 2 Save Buttons in the Store Admin....and the first one just gets stuck when you use it, so it has to be removed.
I ask you these things because haveing thousand of products in the site tree (I'm performing some tests right now) it's really putting sapphire and silverstripe on the hard side...


Community Member, 349 Posts

16 August 2010 at 9:22am

burnbright error
How can i see in page the cart.


Community Member, 349 Posts

16 August 2010 at 11:08am

Got it working


Community Member, 22 Posts

16 August 2010 at 9:27pm

Hi Webdoc,

I have having the same error - the cart is not showing. How did you get it working?



Community Member, 56 Posts

23 August 2010 at 8:29pm


has anyone managed to get any shipping working on 2.4?

I am trying the SimpleShippingModifier::set_default_charge(5); in my _config but fails..
Cant quite figre out where it is going wrong. Any ideas?



Community Member, 48 Posts

25 August 2010 at 7:33pm

I'm trying to extend in the usual way the StoreAdmin class but cannot see any result. I did

class MyOwnAdmin extends StoreAdmin{

	public static $managed_models = array('MyOwnProduct', 'MyOwnProductGroup');

	public static $collection_controller_class = 'MyOwnAdmin_CollectionController';
	public static $record_controller_class = 'MyOwnAdmin_RecordController';

class MyOwnAdmin_CollectionController extends StoreAdmin_CollectionController {


class MyOwnAdmin_RecordController extends StoreAdmin_RecordController {

	public function EditForm() {
		$form = parent::EditForm();
		return $form;

The Store tab at the top of the page is now duplicated but no other effects


Community Member, 48 Posts

2 September 2010 at 8:36pm

dunno if it's my svn working strangely, but found an error with the last branch db_cart when trying to view a product. perhaps i don't have all files up to date?

Fatal error: Class 'ShoppingCart_Controller' not found

In fact, changing in the class product every invocation 'ShoppingCart_Controller' with simple 'ShoppingCart' fixed it

Go to Top