Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, Ed, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba

Problems with using PayPal


Go to End


1585 Views

Avatar
Rawbit

Community Member, 52 Posts

4 June 2009 at 7:41am

I have been having a great deal of grief using the e-commerce module let alone integrating paypal. For example, the e-commerce module doesn't show the $Title of the product in OrderInformation_Editable.ss - there were a number of changes needed to be made including changing to $Title.ATTR - which seems strange to me out of the box.

Anyways, I'm trying to get PayPal integrated as the payment gateway but the closest working setup i've found is here:
http://www.silverstripe.org/archive/show/196242

I have two questions on it so far:

1.) Why is there an intermediate stage where you have to click 'Start Payment Process' (paypalPaymentPage.ss) ? Can this be removed?
2.) Is there an easier way to select country, or have one auto-selected?