Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, Ed, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba

ecommerce install


Go to End


9 Posts   3382 Views

Avatar
widget

Community Member, 19 Posts

5 June 2009 at 11:45pm

I unpacked the ecommerce to my public_html file which contains all my silverstripe folders like - cms, jsparty, sapphire. I added a folder named ecommerce then upacked all of the folders from the ecommerce zip into the ecommerce folder, code, css, image etc .

then i went to "mysite".co.nz/db/build

all i get is an error on the home page =

Website Error
There has been an error

The website server has not been able to respond to your request.

have i missed something or did i do something wrong??

Avatar
widget

Community Member, 19 Posts

5 June 2009 at 11:59pm

all i have done so far is install silverstripe and blackcandy theme. havent made any adjustments to template. then i installed the ecommerce module. maybe i missed a step??

Avatar
widget

Community Member, 19 Posts

6 June 2009 at 12:11am

do i not add a folder "ecommerce" and just add the folders to the root ie code, css, image, javascript etc??

Avatar
DaveP

Community Member, 48 Posts

6 June 2009 at 12:39am

Edited: 06/06/2009 12:44am

Hi Widget,

Have not installed it myself, but there does appear to be quite detailed installation instructions on it's page.
http://doc.silverstripe.org/doku.php?id=modules:ecommerce#setting_up

Have you checked them out ?

Plus the 'install' file in the download should get you started !

HTH Dave

Avatar
boombox

Community Member, 44 Posts

6 June 2009 at 11:36am

Hi - The latest version trunk of the ecommerce module (SVN download) requires the separate payment module to work
Check this post http://silverstripe.org/e-commerce-module-forum/show/258495#post258495

I'll look into getting the SS team to add this as a module available as ZIP download with the eCommerce module

Avatar
widget

Community Member, 19 Posts

6 June 2009 at 11:57am

thanks to you both i will look at both of the posts. also if i dont want the ecommerce to start from the first page and need to click in a tab or link "STORE" do i still install the same way with directory "ecommerce" or do i install further down the tree.?

Avatar
boombox

Community Member, 44 Posts

6 June 2009 at 12:22pm

Edited: 06/06/2009 12:22pm

Hi , Installing the ecommerce module in the root directory of SS code is separate to where you want to make it appear on the website - you use the CMS to select at which level (1st , 2nd, third) etc you want the eccommerce pages (Product Group Page, Product Page) to be displayed.

Avatar
osxboy

Community Member, 1 Post

14 January 2010 at 7:25am

Hi smpmedia

How do I "se the CMS to select at which level (1st , 2nd, third) etc you want the eccommerce pages (Product Group Page, Product Page) to be displayed." I don't see any options in the CMS to do this or am i being dim?

Go to Top