Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

E-Commerce Modules /

Discuss about the various e-commerce modules available:
Ecommerce, SS Shop, SilverCart and SwipeStripe
Alternatively, have a look the shared mailinglist.

Moderators: martimiz, Nicolaas, Sean, Ed, frankmullenger, biapar, Willr, Ingo, Jedateach, swaiba

SilverStripe Shop Inventory module not installing


Go to End


3 Posts   1631 Views

Avatar
Bruce B

Community Member, 164 Posts

15 January 2015 at 4:11pm

I would like to implement the ss-shop-inventory module from Milkyway Multimedia. Unfortunately when I try to install it via composer I get the following message:
Your requirements could not be resolved to an installable set of packages.
Problem 1
- The requested package milkyway-multimedia/ss-shop-inventory could not be found in any version, there may be a typo in the package name.

Has anyone else encountered this problem? and do you have a solution?

Avatar
helenclarko

Community Member, 166 Posts

16 January 2015 at 4:49pm

Hi Bruce B,

Will need more information about your post.

What version of Silverstripe are you using?
What are you entering into Composer?
Have you tried to install the add-on manually?

Regards,
-helenclarko

Avatar
Bruce B

Community Member, 164 Posts

30 January 2015 at 1:11pm

Hi Helen,
Thanks for your prompt response. Another urgent project and failed forum notifications conspired to prevent me from following this up sooner.

In answer to your questions:
The site is running SS 3.1.9
I used the composer string as supplied by milyway-multimedia which I added as a new line in the require list:
"milkyway-multimedia/ss-shop-inventory": "dev-master"
I tried installing the add-on manually but it requires additional bits beyond the folder included on github.

I have just tried a combined manual/composer install: Install the ss-shop-inventory folder manually, then run a composer update from within that folder. That has sort-of worked. Lots of new folders loaded into the ss-shop-inventory folder. Unfortunately, the new folders included a complete new framework folder as well as a vendor folder. Deleting the framework folder gives me something that runs without error but still doesn't work fully.

I get a stock field in the CMS for the product but it doesn't change when stock is sold. I guess i should chase this up with milky way multimedia directly.

cheers
Bruce