Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

Form Questions /

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

[User Error] Uncaught ReflectionException: Class VolunteerRegistrationForm does not exist GET /silverstripe/?flush=1


Go to End


3 Posts   3239 Views

Avatar
CMSPlayer

Community Member, 25 Posts

3 April 2012 at 3:39pm

I got this error when I tried to rebuild the database with my newly created form VolunteerRegistrationForm.php file.

I couldn't understand where it got this error?

Here's the trace of the errors

Trace

ReflectionClass->__construct(VolunteerRegistrationForm)
Line 222 of Object.php
Object::get_static(VolunteerRegistrationForm,db)
Line 264 of Object.php
Object::uninherited_static(VolunteerRegistrationForm,db)
Line 2016 of DataObject.php
DataObject::has_own_table(VolunteerRegistrationForm)
Line 89 of ClassInfo.php
ClassInfo::dataClassesFor(SiteTree)
Line 2254 of DataObject.php
DataObject->buildSQL(HomepageForDomain REGEXP '(,|^) *localhost *(,|$)')
Line 2519 of DataObject.php
DataObject->instance_get_one(HomepageForDomain REGEXP '(,|^) *localhost *(,|$)',)
Line 2464 of DataObject.php
DataObject::get_one(SiteTree,HomepageForDomain REGEXP '(,|^) *localhost *(,|$)')
Line 64 of RootURLController.php
RootURLController::get_homepage_urlsegment()
Line 41 of RootURLController.php
RootURLController->handleRequest(HTTPRequest)
Line 277 of Director.php
Director::handleRequest(HTTPRequest,Session)
Line 121 of Director.php
Director::direct(/)
Line 118 of main.php

I checked the following folders too.

C:\wamp\www\silverstripe\themes\mysite\templates
C:\wamp\www\silverstripe\themes\mysite\templates\Layout
C:\wamp\www\silverstripe\themes\mysite\templates\Includes

where I placed my VolunteerRegistrationForm.ss file.

Obviously the database did not successfully create a record for my 'VolunteerRegistrationForm'.

I'm wondering where did I go wrong?

Avatar
CMSPlayer

Community Member, 25 Posts

3 April 2012 at 8:10pm

Isn't anybody out there who can help me out on this one?

Avatar
AlphaCactus

Community Member, 12 Posts

16 December 2012 at 2:17pm

I had this happen and it turned out that I had forgotten to put the php in <?php at the top of the file.