Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Forum Module /

Discuss the Forum Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Uninstalling forum-v0.1.2

Go to End

3 Posts   1385 Views


Community Member, 6 Posts

21 March 2009 at 3:27pm

I've got a very strange problem...

I tried to update my 0.1.2 forum to 0.2. I just did this by deleting the 'forum' folder on my server, then creating a new folder and copying over the 0.2 files, and then running [mysite]/db/build?flush=1.

Doing that locked me out of the admin, akin to this problem:

I tried this fix:

But it didn't work.

So, I tried reuploading the 0.1.2 version files to the 'forum' folder, and that lets me back into the admin. Fine.

But, I really want to use the new 0.2 version.

So, I tried deleting the 'forum' folder again, and then dropping all of the forum-related tables in the DB:

I run [mysite]/db/build?flush=1 again and it rebuilds all of the forum tables (and locks me out of the admin again)!!

What the heck is going on with this? How can I make the silverstripe install think that I never installed the forums in the first place? If I copy the 0.1.2 forum files onto the server again I can get back to the admin again - also, while in general I've been using a custom theme, during all this madness I've reverted to the default black-candy theme.

I've got all of my tables backed up, so in theory I could nuke the whole SS install and start over from scratch, but I'd rather avoid that if at all possible.

Any ideas about how I can make the 0.1.2 forums go away for good? I'm trying to get a site launched real soon so any help is greatly appreciated...

Thanks for any help!


Community Member, 6 Posts

22 March 2009 at 6:30am

I gave up and reinstalled SS, installed the .2 version straight away and everything seems fine. I'd still like to know how to cleanly uninstall the forums module though...


Forum Moderator, 5523 Posts

22 March 2009 at 10:25pm

To do a 'clean' uninstall you should just need to delete the forum folder and remove all the forum* database tables (which i think if you remove the module 2.3 should rename the tables to _obsolete_forum*.

As for the error - you should turn on development mode ( when upgrading modules as this will report any warnings and errors in full rather then the generic error page.