Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Forum Module /

Discuss the Forum Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

* Solved* cannot post on forum module

Go to End

11 Posts   3265 Views


Community Member, 56 Posts

19 February 2010 at 5:33am

I found that by editing sapphire/security/Security.php

line 179

if($member = Member::currentUser()) {

if($member = Member::currentUser()) {

fixed the problem in blackcandy theme & showed useful output to the user.


Community Member, 98 Posts

4 March 2010 at 5:27am

Edited: 04/03/2010 5:37am

I'm having the same problem, however I've gone into the Security.php file and made the suggested changes, however now it tells me "I'm sorry, but you can't post to this forum until you've logged in. If you want to log in as someone else, do so below. If you're logged in and you still can't post, you don't have the correct permissions to post." while telling me who I am logged in as. I am in the administrator's group, I've tried changing the permissions in the CMS so that anyone can post, but it won't allow it. Any other suggestions? Thanks.

---I am using External Authentication and wonder if that is what is causing the problem? Also, I don't get a "registration" option. When I go to the forum page, it knows me even though I am not in the Forum Members in the CMS (I added me as a forum member in the CMS but it made no difference, still no access).


Community Member, 2 Posts

26 March 2010 at 5:38am

I also have done the suggested fix and have the same result as the last post -- how to fix this???

Go to Top