Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Forum Module /

Discuss the Forum Module.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

"starttopic" doesnt work


Go to End


6 Posts   1563 Views

Avatar
baba-papa

Community Member, 279 Posts

14 April 2009 at 4:49am

Hi,

I installed the forum module to my site and I really like it. Since I added some more features, eg the mollom-Module, the method "starttopic" doesn´t work any more. If a user of any group tries to start a new topic, a white page with no html-code at all appears, nor any error message. Since I´m new to saphire and SilverStripe I don´t know how to track down this error. The method starttopic resides at the Forum_Controller.

I´m sure it´s just a small error, I tried to find it for hours. I appreciate any help or hint.

Avatar
baba-papa

Community Member, 279 Posts

14 April 2009 at 9:51pm

I might have solved this by myself. Since I was developing on my localhost and had no internet access, the mollom spam protection did not work well and i got these odd results.

Avatar
mwalsh

Community Member, 21 Posts

17 April 2009 at 1:05am

I'd be interested to learn how you resolved this issue.

I have the same issue in that I'm unable to start a new forum topic (SS 2.3.1 and latest stable forum release - I've tried the SVN trunk too). I seem to be able to post to the forum on existing topics but I'm unable to start new ones.

Avatar
baba-papa

Community Member, 279 Posts

17 April 2009 at 6:17pm

Edited: 17/04/2009 6:27pm

I´m quiet shure, that the bug had something to do with the mollom-module or the spamprotection-module. I didn´t fix that bug nor did I find it´s cause. Although my system is in developer mode I had no error message at all. The problem went away when I came back from hollyday and had internet access again.

Avatar
HansR

Community Member, 141 Posts

30 May 2009 at 5:48pm

I just had this problem, and it was an issue with my theme, which has its own custom forums theme. I think that the problem was the following line in Forum_starttopic.ss:

$ReplyForm

which should be:

$ReplyForm(true)

My solution was to copy the Forum_starttopic.ss from the forum/template/ folder. I suppose deleting the custom forum theme would work too.

Hans

Avatar
baba-papa

Community Member, 279 Posts

1 June 2009 at 10:14pm

Hello HansR,

thanks for your help. Next time I´ll try your way.