Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

ss2.4 beta, i18n, prototype and jQuery noconflict

Go to End

13 Posts   3278 Views


Community Member, 89 Posts

8 February 2010 at 2:23pm

I'm just wondering why it can't find the separator? It's a div on maybe prototype does not get loaded and that's why $('separator') returns null? Just a thought.


Community Member, 127 Posts

8 February 2010 at 7:31pm

The problem I had seen must have been from the upgrade 2.4 alpha to 2.4 beta.

After I made a fresh install of 2.4 beta
- plus all modules and widgets as before
- plus all code changes I had made before
- plus re-importing the sitetree,
the 2.4 beta still worked fine, no problems :)


Community Member, 203 Posts

9 February 2010 at 2:34am

Edited: 09/02/2010 2:37am

Thankx for the answer it helped me get one step further, but I still have the problem that my Newsletter Module or UserDefinedForms loads an extra jQuery file at the end of the rest of the requirements that messes my code up (and Requirements::clear(); does not help me get rid of it)

I will try and find a way to extend the class and put the clear function there, but then I probably also have to crete my own validation there....

I will also put a post in the other modules forum, and hope for an answer there...

EDIT: Got it, I just have to require the same jQuery file the module requires and put that one in the right spot in my code. Somehow I do not like it but I can live with it :-)


Community Member, 89 Posts

9 February 2010 at 8:52am

Sorry for hijacking your thread :)
Did you know you can always Requirements::block one specific file? Quite handy.


Community Member, 203 Posts

9 February 2010 at 9:30pm

Tried Requirements::clear() but that did not work - I guess because the Subscription Page is a descendant of Page, after that I stopped trying

NP with the hijacking :-)

Go to Top