Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

HELP! [Notice] Trying to get property of non-object

Go to End

3 Posts   3638 Views


Community Member, 10 Posts

3 March 2010 at 7:04am


i added a new usergroup and new user in my Backend. After that i logged out and tried to login as a new user of the new usergroup.
But than i got this massege in my browser:


[Notice] Trying to get property of non-object
GET /silverstripe/admin/

Line 243 in C:\xampp\htdocs\silverstripe\sapphire\security\Group.php

234 return $familyIDs;
235 }
237 /**
238 * Returns an array of the IDs of this group and all its parents
239 */
240 public function collateAncestorIDs() {
241 $parent = $this;
242 while(isset($parent)) {
243 $items[] = $parent->ID;
244 $parent = $parent->Parent;
245 }
246 return $items;
247 }
249 /**


* Group->collateAncestorIDs()
Line 669 of Member.php
* Member->Groups()
Line 257 of Permission.php
* Permission::groupList(3)
Line 160 of Permission.php
* Permission::checkMember(Member,CMS_ACCESS_CMSMain)
Line 86 of LeftAndMain.php
* LeftAndMain->canView()
Line 123 of LeftAndMain.php
* LeftAndMain->init()
Line 84 of CMSMain.php
* CMSMain->init()
Line 110 of Controller.php
* Controller->handleRequest(HTTPRequest)
Line 277 of Director.php
* Director::handleRequest(HTTPRequest,Session)
Line 121 of Director.php
* Director::direct(/admin/)
Line 118 of main.php


What is wrong? What can i do now?

Thanks a lot...


Community Member, 541 Posts

3 March 2010 at 1:48pm

Usually I get this error if i am trying to access the methods, variables of an empty dataobject set.

Seems odd that this error would be generated by the core CMS. Is the group you created a root level group? Or is it a child of another group?

Also, what version of SS are you running? Have you got any additional modules?




Community Member, 10 Posts

5 March 2010 at 4:42am

Edited: 05/03/2010 4:46am

Hi Mo,

thanks for posting.

I found a soluiton. I hope its the right one. But now it works again.

I changed the parameter of ParentID from 2 to 0 in the "group" table (database). And now it works.

But ist this normal, that one "wrong" parameter knock out the whole CMS incl. Backend??
I just added an new usergroup and added a new user to the group.