Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Admin accounts are not working?


Go to End


3 Posts   1210 Views

Avatar
dynamite

Community Member, 66 Posts

3 March 2010 at 11:47am

Hello -- something went wrong with one of my SS installs, and the admin accounts keeping getting kicked back with the error message:

You don't have access to this page. If you have another account that can access that page, you can log in below.

I know it is not a password issue - I even used "Security::setDefaultAdmin" in my config to make sure.

Also, I have tried a /dev/build?flush=1 but it didn't seem to change anything or repair any tables. I ran a MySQL table check/repair, and also checked the tables Groups, Permssions, Group_Members and Members but it all looks good.

Does anyone have any ideas for me on what to check next? Thank you very much!

Avatar
carlos

Community Member, 42 Posts

3 March 2010 at 2:36pm

Edited: 03/03/2010 2:37pm

Hi,

Did you check you DB? using phpmysql or something else?

Have you tried "I've lost my password" link?

cheers

Avatar
dynamite

Community Member, 66 Posts

4 March 2010 at 10:39am

I found the problem, but still need a more permanent fix...

I incorrectly assumed that the "canEdit" method was only for the API calls.

Once I commented out the following line in my code/Page.php, it started working again.

function canEdit() { return false; }

So... does anyone know how to deny access to editing for API calls only?

Thanks!

~ Jeremy