Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Upload broken in 2.4?

Go to End

55 Posts   16011 Views


Community Member, 4 Posts

23 July 2010 at 2:29am

Edited: 23/07/2010 3:47am

Hi all,

i've had the same problems with FileUploading.
This morning i installed the latest SS Release with several strange problems.
After the 5th reinstall it worked fine, but i couldnt upload any files.
After applying the patch mentioned in this topic it all worked fine for me, even the WYSIWYG editor still works.

One little bug is still there, by editing content in IE8 i always get an Error when trying to save the changes.
That Problem doesn't appear in Google's Chrome... :D

Thanks very much :D
I hope the installation of modules runs less complicated ;)



Community Member, 59 Posts

26 July 2010 at 4:17pm

The patch a few pages back worked for me too.


Community Member, 114 Posts

4 August 2010 at 7:17am

adding this to my vhost conf file worked, fyi.

php_admin_value open_basedir none


Community Member, 15 Posts

5 August 2010 at 11:36pm

:-(((( my first realy bad expirence with silverstripe :(

it runs local but nut on my webserver... i have open_basedir = no value in my phpini.
i have 777 on assets and sub.

when i upload i get no error but my swfupload end like that:

SWF DEBUG: ReturnUploadStart(): File accepted by startUpload event and readied for upload. Starting upload to for File ID: SWFUpload_0_0
SWF DEBUG: Event: uploadProgress (OPEN): File ID: SWFUpload_0_0

on my local system i get a 41 responde that my upload is completed. here the debug ends like that. i have no js erros...

I tried:

Do I just need the 2 Files there to fix or the other files in 5547 too?

Plz help. its a realy big site, that have to online in 3 days :(


Community Member, 6 Posts

11 August 2010 at 4:38pm

Edited: 11/08/2010 4:41pm

Timtim's solution of changing open basedir fixes the problem for me, on latest SVN build - Patch earler broke TinyMCE, without patch this fixes upload and TinyMCE still works, whether applied through php.ini, vhost.conf or httpd.conf.


Community Member, 114 Posts

18 August 2010 at 4:28am

what if you don't use SWF upload?

in a pinch you could also manually upload the files and run "Look for New Files" from files/images tab.


Community Member, 15 Posts

18 August 2010 at 7:11pm

how to switch off swf upload in assets ?

i still have the problem that i only can upload with admin rights. editor can´t upload.


Community Member, 114 Posts

19 August 2010 at 5:58am

you are using swfupload from dataobject manager, right? I think you can just remove that directory from your root and do a build - somebody correct me if I'm wrong there.

also, by manually I mean use an (s)ftp client to upload your files to assets then 'look for new files' and see if that works. if you are on deadline that could buy your enough time to do a real fix. ;-)