Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Upload broken in 2.4?

Go to End

55 Posts   16099 Views


Forum Moderator, 5523 Posts

1 May 2010 at 12:47am

You may want to create a bug report if you have not yet done so on Some common things to list when you create a new ticket

* Check - has anyone raised this issue? or is it in progress?
* Rather than using your site, checkout a new version of it Fresh DB, no modules, new folder... Is the bug still there?
* If the RC is broken have you tried a build straight from svn (though 2.4rc2 was tagged like 6 hours ago so not much would have been fixed)
* Your server setup. Include your configuration information.
* Include a screenshot on the ticket.

A well written bug submission to goes along way to getting someone to look into the issue. Personally I haven't run into it in my testing but thats just me.


Community Member, 98 Posts

7 May 2010 at 2:29am

Edited: 07/05/2010 3:04am

I've been having the same problem - but it's getting worse. At first I could not upload a file, but could ftp the file directly to the server then successfully link to the file. Today I still can't use Upload, and when I ftp directly to the server, although I can see the files and link to them, when I click the link, it gives me "Sorry, it seems you were trying to access a page that doesn't exist. Please check the spelling of the URL you were trying to access and try again." although the url is correct.

I did try a brand new installation of Silverstripe version 2.4.0 and the CMS opened with a blank page, the same as it did when I upgraded my current site, and I reverted back to 2.3.7. I am now in 2.3.7 and having this problem with the uploads.

I did go to and saw the "File uploads in the Asset admin area" ticket which seems to address this problem, but when I click on the patches, what am I supposed to do with them? Can I get any info on how to apply them?

Thank you.


Community Member, 175 Posts

15 May 2010 at 5:25am

hi jseth,

make a copy of the 2 files showed in this file-diff:

then edit this 2 file as you see there -> green means add this code, red means remove this code

This patch worked for me.



Community Member, 323 Posts

19 May 2010 at 12:06am

Thank you!

I can confirm that those diffs resolved the issue for me too.

Best regards,


Community Member, 470 Posts

19 May 2010 at 1:05pm

I'm also having the exact same problem on a brand new install.

Will look into the patch, but wanted to give a heads up that it's happening to more people as well.


Community Member, 98 Posts

20 May 2010 at 12:06am

Edited: 20/05/2010 12:07am

Thank you for your reply. I have not tried your fix yet, (I'm staying with 2.3.7 for now) but I appreciate your response, and from other's posts, it appears to do the trick. There were a few issues that I had when I tried to upgrade to 2.4, and I guess I got spoiled by the two previous upgrades going so smoothly, but do you think that it there is any harm in waiting to upgrade until these and other issues are addressed in the complete version? I don't really look forward to having to patch this and that after installing an upgrade. Thank you again.


Community Member, 17 Posts

20 May 2010 at 10:30pm

This patch resolved my issue as well. Thanks!


Community Member, 211 Posts

20 May 2010 at 10:40pm

Me too !

I guess this issue is solved