Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Site Search function not working properly for certain page and keywords


Go to End


6 Posts   995 Views

Avatar
PeterLu

Community Member, 8 Posts

10 January 2017 at 4:49pm

Page is https://www.hrblock.com.au/income-tax-course
Page name is Australia's leading income tax course, and page content contains a lot of "income", "course", "tax" wording.

But If I do a keyword search for "tax course" or "course", the page does not show up in the search results.
Any ideas why?

Thanks,
Peter

Avatar
Guy Van Bael

Community Member, 61 Posts

23 January 2017 at 8:25pm

Edited: 23/01/2017 8:26pm

Did you manage to sort this out? I'm having the same problem. Some words can't be found...

Avatar
PeterLu

Community Member, 8 Posts

23 January 2017 at 8:38pm

Nope, still waiting for answer.

Avatar
martimiz

Forum Moderator, 1391 Posts

3 February 2017 at 3:52am

That's hard to say, really. I suppose you're using default fulltext site search? Have you checked the page settings to make sure that 'Show in search' isn't accidentally disabled?

Also default search only searches SiteTree -> (Title, MenuTitle, Content, MetaDescription) and File -> (Filename, Title, Content). So if you're using other fields, matches will not be found.

Avatar
Guy Van Bael

Community Member, 61 Posts

3 February 2017 at 5:00am

Edited: 03/02/2017 5:01am

I've narrowed it down to this. It's probably a mysql setting (minimum word length that get indexed). Problem is... if on shared hosting, provider probably won't change it to 3. According to my information default is 4. Would be nice if it could be set from SS_config though.

Avatar
martimiz

Forum Moderator, 1391 Posts

3 February 2017 at 10:58am

@guy - yes that's not really fixable on shared hosting.

I've noticed that on MySQL 5.6, where you can do a fulltext search on InnoDB tables, in some cases a minimum of 3 character seems to be enabled by default for some reason... so if you're on 5.6, and you're still using MyISAM you could try converting tables to innoDB...

I think PeterLu's problem is different, because he's searching on 'course' and still not finding his page.