Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

can't log in to cms / extra entries in password table/ 404 errors

Go to End

2 Posts   3947 Views


Community Member, 79 Posts

7 April 2010 at 10:50am

Edited: 07/04/2010 10:52am

I upgraded to 2.4.0-rc1 and except for a few minor issues it worked fine for a while, then suddenly I couldn't log into the cms. error message was "That doesn't seem to be the right e-mail address or password. Please try again." I looked for an easy fix but I didn't have time to play around so I deleted 2.4.0-rc1 and loaded 2.3.7. I've done this twice and I still can't get in.

My next step was to check the member and member password tables to make sure that the ids hadn't been dropped. There are two users and both were listed in the member table, but the password table showed four entries. This didn't look right to me, but I have no idea how to fix it. I thought about deleting the extra entries but wasn't sure which ones were wrong, so I left it.

I then moved on to creating a generic login in config.php by adding the line

Security::setDefaultAdmin('username', 'password');

The generic login got me into the cms, but I was still unable to reset my admin login. When I looked at the admin group on the security tab I could see the two users, but there was no password set for either. There was also a third user with my email address and a password but no username. Every time I tried to display or edit any of the users I got a 404 error.

I've cleared cache, removed all the modules updated for 2.4.0, flushed and reinstalled the cms a few times now and still can't get past this. Does anyone have any idea what else I can try? The generic username and password gets me into the cms, but I'm unable to save anything. (I tried saving a page and got a 404 error) It seems like it is more than a password issue.




Community Member, 79 Posts

8 April 2010 at 12:26am

Edited: 09/04/2010 12:29am

New day, new attempt. I was really sick and hadn't slept in a few days when I did the original upgrade. Clearly I should have stayed on the couch. I didn't take any notes and now that I am better have no idea what I did to get from a decent install with only a few minor issues to being completely locked out. I ended up having to restore the database from an earlier backup, but I did manage to return things to a working state.

The moral of the story is that if you are too sick to drive or work you should not be tinkering with things on the server. Lesson learned.