Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Search does not find 3 letter words


Go to End


5 Posts   2039 Views

Avatar
purplespider

Community Member, 89 Posts

29 April 2010 at 4:12am

I'm using the standard SilverStripe search, but it does not find any 3 letter words, is there anyway to change this limit?

Thanks
James

Avatar
neilcreagh

Community Member, 136 Posts

8 October 2010 at 4:11am

Anyone got any ideas about this? I need the search results to throw back results for two letter searches (products are known as 'V3' or 'V4' etc.).
?? Running 2.4.2

Avatar
swaiba

Forum Moderator, 1899 Posts

8 October 2010 at 4:32am

I just tried this (a couple of 2.4.0 sites) and there were some strange results... I got results for 'on' or 'to' and get page results, but not '4u'... I tried with with single/double quotes and without.

Avatar
purplespider

Community Member, 89 Posts

13 October 2010 at 1:58am

I did manage to fix this. It's not a limitation of SilverStripe, it's actually due to a default setting of MySQL.

You need to change the "ft_min_word_len" MySQL variable on the server. The default is 4, changing it to 3 will allow 3 letter searches to work etc.

James

Avatar
borriej

Community Member, 267 Posts

24 January 2011 at 10:32pm

how do you change the mysql setting?
Through htaccess?
Im not hosting my own server, but in the Netherlands we usually pay for hosting on a shared server.