Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Disabling SS error messages? help Please

Go to End

2 Posts   1372 Views


Community Member, 74 Posts

1 May 2010 at 2:58am

Hi all,

Having a little problem with error messages being displayed, I want too disable SS (you know blue bg with ss logo top left) error messages and use my own for the site design.

for example if I type a URL that does not exist I get :

Website Error
Not Found

The website server has not been able to respond to your request.
(blue bg with ss logo top left)

Instead of my custom 404 - not found :

Sorry, it seems you were trying to access a page that doesn't exist.

Please check the spelling of the URL you were trying to access and try again.




I read somewhere to add set_environment_type("live");

But does not seem to work am I missing something simple?

thanks in advance



Forum Moderator, 5523 Posts

1 May 2010 at 9:58pm

Do you have a error-404.html page in your assets folder and a 'Page Not Found' Page in the CMS? If theres no 404 template then it could be throwing an error. If you put it in devmode you might need to check its not another error.