Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Admin splash screen stuck!

Go to End

6 Posts   2678 Views

Pixel Labs

Community Member, 14 Posts

25 May 2010 at 2:29am

Hi guys, I don't think I've altered anything in the site structure beyond the mysite and themes folders.

I installed the Jobs module from the book tutorial and setup some virtual pages but thats it.

It was all working but now when I login I get stuck on the white splash screen with the SS logo and the 'Loading...' text in the corner.

Anyone else had this problem? It's got me really perplexed. The CMS is loaded, I can see it when I 'View Source' but the splash screen is covering it.

I'm on version 2.4.0 by the way.

Please help! Thanks!


Forum Moderator, 5523 Posts

25 May 2010 at 11:35pm

If the loading screen isn't disappearing this usually relates to a Javascript error (ts missing a js file, or a syntax error in the js). Do you get any errors in your webbrowsers console panel?


Forum Moderator, 1899 Posts

26 May 2010 at 2:08am

This may sound crazy but try a full refresh - I just had this unexpectedly with errors like '$ not defined' and 'jQuery not defined'.

I knew it was rubbish because it worked fine in another browser - so in firefox I did 'Ctrl + F5' and the cms loaded.

Hope that helps...


Pixel Labs

Community Member, 14 Posts

26 May 2010 at 4:03am

Cheers for the help. I ended up re installing SS, which fixed the problem!
Not the best solution I know but since I'd only just got started I thought it would be a quicker solution.


Community Member, 99 Posts

21 June 2010 at 8:46am

hi there, i had this problem too - admin worked first time, but then when i logged back out and logged in again it stuck at the splash screen, trief ctrl F5, ?flush=1 etc and nothing worked.

Anyway, found this fix on one of the other posts...

In your _config.php file add the following line of code:



Community Member, 29 Posts

7 April 2011 at 6:30am

Thanks Linsey for posting up the solution on this thread as it came in handy.

Any idea what the original thread where you got this from is? What exactly is this doing and why is it fixing it? I guess I'm trying to understand what exactly I'm doing by adding this to my _config.php file.