Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

2nd (non-Silverstripe) website in ftp subdirectory

Go to End



Community Member, 1 Post

3 September 2010 at 12:04am

Hi everyone,

I've got following problem:

I've installed Silverstripe in the root-directory of my ftp. You can reach the site at and everything works fine.
Now, for nostalgically reasons, I've put an old website of mine in a new subfolder at the same ftp (called "/old"). The registered domain for this old site is

The old site contains some html and swf files and local this old site works fine.
In my webhosters' account I've set the assignment of to "webspace (/old)".

I'm able to reach the index.htm of my old site (situated at /old/index.htm).
On this index.htm site is a link to an swf-file "first" ("first.swf" is located at /old, same directory as index.htm). This swf-file is shown correctly in the browser.
When the "first" site is loaded in the browser then there are 1 html link (directing to a contact.htm) and 1 link to another swf-file "second" (also in the /old folder). Clicking the contact-link is no problem, the html-site shows up in the browser.

But when I click on the "second" link then nothing appears.

In the safaris activity-log it says "internal server error".
If I address the "second" site directly in my browser all works fine.

I don't understand why the link to an html-site is working an to an swf-file not.

I've tried several rewriterules in the .htaccess file but nothing worked. As I'm not comfortable with editing htaccess-files maybe I didn't put the correct statements in there.

Does someone have an idea on how to solve this problem?

Thanks & Greetings