Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Excessive RAM/CPU usage


Go to End


2 Posts   1909 Views

Avatar
SightUnseen

Community Member, 28 Posts

20 August 2010 at 6:08am

We're having issues where SilverStripe is taking the VPS it is running on down due to spiralling CPU/RAM usage.

The site was ok until we upgraded to 2.3.7 about a month ago, and since then we've had ongoing issues with Apache using more and more RAM until it eventually chokes the server and a restart is required. RAM usage on the VPS in question is usually 290-320MB but since this issue has occurred it will eventually rise to 800-900MB and more, before finally killing the VPS.

Running lsof -p xxxx on various httpd processes shows that the initiating path is /httpdocs/sapphire. How do we go about troubleshooting and rectifying this?

Avatar
swaiba

Forum Moderator, 1899 Posts

20 August 2010 at 8:38pm

Just like to bump this and point to http://www.silverstripe.org/general-questions/show/289167#post289167 where I have loads of info where I have the same issue accross several ss installs... sound like opening a ticket would be best...