Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

CMS Page Tree switching between pages on Main tab causes error


Go to End


5 Posts   1262 Views

Avatar
1k2k3

Community Member, 15 Posts

16 August 2010 at 4:29pm

Edited: 16/08/2010 4:53pm

Hey,

I just installed SilverStripe v2.4.1 fresh from http://silverstripe.org/stable-download/

And after I log into the CMS Backend of the website there are some issues which I found. This is after selecting 'Site Content' And clicking on 'Home' from page tree while on 'Main' or 'Content' tabs.

http://img411.imageshack.us/img411/5862/startherei.gif

Bug #1.
No Scroll Bar, is this a bug?
http://img185.imageshack.us/img185/7309/cluttered.gif

Bug #2.
Why is the metatag and SEO area on the same page as the content?
http://img535.imageshack.us/img535/7716/noscrollbar.gif

Bug #3.
No formatting tools

Bug #4
Can't change themes.

Solution?
only way I can see about fixing these 'bugs' is refreshing the page http://localhost/silverstripe/admin after every time I want to modify or create a new page which is very inconvenient. I also found that if I switch between pages on a different tab and not on 'Main Tab' the error goes away.

So my question is.. should I stick with v2.3.7 which seems more stable or move to v2.4.1 so the Newsletter module works?

Avatar
Martijn

Community Member, 271 Posts

16 August 2010 at 6:44pm

This seems like a javascript error somewhere, since the tabs are not tabbed..

Check where you have a javascript error with firefox errorconsole or even better firebug.

Avatar
1k2k3

Community Member, 15 Posts

16 August 2010 at 9:02pm

Have you been able to duplicate my problem?

Avatar
Martijn

Community Member, 271 Posts

16 August 2010 at 9:06pm

No, but to locate the problem we need to know what javascript error message you get.

Avatar
1k2k3

Community Member, 15 Posts

18 August 2010 at 12:13pm

Mmm I haven't been able to recreate the issue :(