Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

UserDefined Form - CSRF attack.


Go to End


12 Posts   4673 Views

Avatar
Stijn

Community Member, 46 Posts

7 July 2010 at 5:45pm

Hi,

When I save an userdefined form that I make, I get this error in FireBug:

400//SecurityID doesn't match, possible CSRF attack.

What can I do?

Avatar
Stijn

Community Member, 46 Posts

8 July 2010 at 6:14pm

Up ?

Avatar
Stijn

Community Member, 46 Posts

8 July 2010 at 8:40pm

I'm using the latest SilverStripe version (2.4)

Avatar
Webdoc

Community Member, 349 Posts

9 July 2010 at 2:31am

Form::disable_all_security_tokens();

to _config.php

Avatar
Stijn

Community Member, 46 Posts

9 July 2010 at 5:47am

When I add the code: nothing happen when I click save & publish

Avatar
TotalNet

Community Member, 181 Posts

9 July 2010 at 10:06am

I'm using the latest SilverStripe version (2.4)

silly question, but are you using the latest version of UserDefinedForms? 0.3 I believe.

Avatar
Stijn

Community Member, 46 Posts

9 July 2010 at 5:52pm

Yes I'm :-)

Avatar
martimiz

Forum Moderator, 1391 Posts

10 July 2010 at 10:05am

Often, when the CMS 'hangs' on saving content, FireBug will reveil the error...

Go to Top