Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

[Notice] Use of undefined constant SAPPHIRE_DIR - assumed 'SAPPHIRE_DIR'


Go to End


3 Posts   1722 Views

Avatar
bunheng

Community Member, 78 Posts

26 October 2010 at 5:22pm

Hi,

I just completed the installation of SilverStripe the site working fine but inside the admin
i can't edit albumn create directory and upload photo as well, I always got the following error:

[Notice] Use of undefined constant SAPPHIRE_DIR - assumed 'SAPPHIRE_DIR'
GET /admin/assets/EditForm/field/Files/upload
Line 767 in /home/cambod93/public_html/dataobject_manager/code/DataObjectManager.php

I really appreciated if someone know this issue.

Regards,
Bunheng
http://www.cambodia-wildlife-adventures.org

Attached Files
Avatar
Sean

Forum Moderator, 922 Posts

26 October 2010 at 6:39pm

You'd best ask that in the DataObjectManager forum, as it looks like it comes from that module.

Sean

Avatar
bunheng

Community Member, 78 Posts

27 October 2010 at 6:30am

Edited: 03/11/2010 4:08pm

Hi Sean,

Thanks for your quick reply, I post the same topic at DOM, but there is no response yet. Is it any possible problem from the hosting? I am running XAMPP it was working fine in my machine.

Thanks.
Bunheng

Resolved
Because I put
Director::set_environment_type("dev")
just take it out now working fine.