Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Redirect loop when visiting level 3 pages

Go to End

4 Posts   1303 Views


Community Member, 89 Posts

22 November 2010 at 2:51am

Edited: 22/11/2010 2:51am

I'm starting to panic a bit, as I've just copied a SilverStripe site across to the client's hosting account, due to go live tomorrow morning, but a bug has appeared that didn't happen on my staging account:

Basically, upon trying to access a page on the site which is on the 3rd level, for example:
It goes into a constant redirect loop:
until the browser catches it and kills it with a redirect loop error.

If I turn off nested pages it works fine. I've got no redirects setup in the code, I've tried clearing the cache and flushing etc, but I can't get rid of it!

Any ideas?

Many Thanks


Community Member, 89 Posts

22 November 2010 at 5:05am

This is really starting to baffle me now:

  • Tried a fresh SS install, created a level 3 page, redirect loop still appears
  • Removed .htaccess file and accessed a level 3 page using index.php, loop still happens!
  • Tried creating 3 sub folders on the server, visited the 3rd folder, redirect loop did NOT occur.

This tells me that this is caused by a setting on the server that SilverStripe doesn't like, and that it's NOT a htaccess issue, but I might be wrong.

Any ideas? Pulling my hair out here!



Forum Moderator, 1899 Posts

23 November 2010 at 10:28am

might be a corrupt sitetree in the database, i've had some strange things happen there - have you copied / upgraded / done stuff to the database? I've seen emtpy classnames but if I were you I'd check pages with parents in a circle loop - start with the urlsegments page1/page2 in your - if you can start with a fresh site tree and see how that works out


Community Member, 89 Posts

3 December 2010 at 12:10am

Thanks, I've had a quick look through the SiteTree table but can't see anything odd.

But the strange this is, I tried a fresh SS install, dropping the old database, and upon creating a level 3 page in the CMS, and trying to access it I had the same problem.

The only thing I can think it could be is a strange issue with the host, but I don't know what!