Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Partially Solved: Unable to upload files via "Files & Images" in 2.4.2

Go to End

2 Posts   1310 Views


Community Member, 99 Posts

11 December 2010 at 6:41am

Hi there,

Working with an install of SS 2.4.2 on IIS server.

Up until now I had been uploading the files directly into the assets folder then using "look for new files" to add them to the database.

However, was getting ready to show client how to use the CMS and realised that I cannot upload via "Files & Images"

You can see a screenshot here:

Basically neither the "Upload New" or "Choose Existing" buttons work - if i click them, nothing happens. Although I can select a file with Browse..., once I've done that I can't upload it - it just stays at "no attached files" - there is nothing to click to attach the file (the button thats partially hidden is just the continue button - clicking this doesn't upload the file either)

I've never used this particular upload format before either, so i have no idea where to start. I think its perhaps to do with the dataobject manager...

I am absolutely baffled. Really hope you can help me fix this as I am hoping to launch site on tuesday and train client next week.

Never seen anything like this before!

Many thanks,



Community Member, 99 Posts

11 December 2010 at 9:20am

OK, I've fixed this just now. (sort of!)

I installed all the files (apart from dataobjet managed and uploadify) on my own linux server which has loads of SS sites running no problem.

Logged in - I could upload fine, system was using the original version of the "Files & Images" upload.

Then in uploaded the DataObjectManager and Uploadify, did a rebuild, flushed the CMS and went back to Files & Images.

I got the exact same result and screen layout as on the IIS server screenshot in the original post (see above). Unable to upload files and strange modal layout.

However, i found that in the following file:


I could change this setting to false:

// Allow DataObjectManager to take control of the AssetAdmin using the AssetManager field

And once I did that and flushed the CMS I was back to the original style of upload and was able to upload files no problem.

Am not sure what was wrong with the newer version, but am just glad for now that I can upload files!