Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We've moved the forum!

Please use forum.silverstripe.org for any new questions (announcement).
The forum archive will stick around, but will be read only.

You can also use our Slack channel or StackOverflow to ask for help.
Check out our community overview for more options to contribute.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

IE errors.. i know, but please read :)


Go to End


5 Posts   1795 Views

Avatar
borriej

Community Member, 267 Posts

7 March 2011 at 9:04am

Hello,

Im debugging my website in IE 8 & 7 and im getting some JS errors..
comming from featuredvideo widget js.

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.2; .NET4.0C)
Timestamp: Sun, 6 Mar 2011 19:53:55 UTC


Message: Object expected
Line: 1050
Char: 1
Code: 0
URI: http://www.url.nl/widgets_featuredvideo/js/effects.js?m=1299433722


Message: 'Prototype.Browser.IE' is null or not an object
Line: 1003
Char: 3
Code: 0
URI: http://www.url.nl/widgets_featuredvideo/js/lightwindow.js?m=1299433722

How do i fix these?

Avatar
web2works

Community Member, 50 Posts

7 March 2011 at 9:34am

I always disable the default javascript with this in your config

//Disable Default JavaScript Behaviours
Validator::set_javascript_validation_handler('none');
PageCommentInterface::set_use_ajax_commenting(false);

Avatar
davidm2010

Community Member, 107 Posts

7 March 2011 at 11:06am

Great tip. This was for another issue, but it worked.

Avatar
Miklosh

Community Member, 1 Post

23 June 2011 at 12:28am

Edited: 23/06/2011 12:35am

I'm also debugging my website in IE 8 and IE 7 and I'm getting this java tm plug-in 2 ssv helper jp2ssv.dll each time I open up IE (takes a few seconds and then it pops up). Any idea how to fix this? (Without removing this plug-in).

thanks,

Miklosh.

Avatar
Stevie

Community Member, 5 Posts

23 June 2011 at 1:56am

Hi Miklosh,

That error is limited to your computer, if you follow the registry fixing steps mentioned in your link it will be fine - other users shouldn't get this error unless they are having a similar issue with their browser.