Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Themes exist but won't show, even when selected

Go to End

6 Posts   1541 Views


Community Member, 4 Posts

1 April 2011 at 8:39pm

Hi all

Having a nightmare here. I tried to install the blog module on to my SS site, but something went wrong and all I got were errors when I tried to view my site or CMS. After trying a few fixes mentioned on forums to no avail, I went for the fresh install option to remove whatever files were messing things up.

After deleting the site and re-installing SS I got a CMS that links to my DB, had all of my previous pages in it as well as the options to select all the custom page types and the custom theme that I'd developed.

However, when viewing the pages the theme didn't appear and all I got was my content with the message:

'Generated with the default template'

I also couldn't see any of the customisations that I had made to the CMS. It also won't recognise the native SS themes like blackcandy.

After browsing these forums I think is must be that the layout, and template '.ss' files aren't being read as none of my includes appear in my page content, but I have no idea how to force them to be applied.

Oh, and I've I've rebuilt my database, and I've flushed the cache many, many times.

Please help, I've reached head-banging-against-wall point with this.



Forum Moderator, 1899 Posts

1 April 2011 at 9:57pm

as well as selecting it in the cms (and doing a dev build)
try adding...


in your _config.php


Community Member, 473 Posts

1 April 2011 at 10:06pm

This sounds rather like SilverStripe forgot the page type of your pages. In the CMS, check the page type in the Behaviour tab.


Community Member, 4 Posts

2 April 2011 at 6:33am

Hi Simon and Swaiba

Yup, the page types are available but when I swap between them it makes no difference, there is no styling on the pages at all. I've also checked my config.php file and the SSViewer::set is set to the correct theme. Even when I change that or the theme on the CMS or the page type, no styling at all appears, even blackcandy the default renders nothing.

Thanks for your input folks...


Forum Moderator, 1391 Posts

2 April 2011 at 10:05pm

Simon has a point though, check the database for empty ClassName fields. If you find any, just set them to 'Page'.

I've had this happen when I removed a certain pagetype from source and dev build. After that even saving the page wth a new classname wouldn't fix it, so I ended up editing the tables. After that you can save to the correct page type. Hope this helps...


Forum Moderator, 1899 Posts

3 April 2011 at 12:39am

yes I agree - I noticed this after an upgrade also