Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

/dev/build not working

Go to End

3 Posts   1078 Views


Community Member, 2 Posts

24 June 2011 at 3:38am

Hi everyone

Whenever I try to get the database to update by using localhost/dev/build in the browser, I just get the browser telling me that the page doesn't exist.

My site isn't at the root of the server so I've tried localhost/mysite/dev/build before diverting back to the standard one above. I've also tried db/build, with and without a slash on the end, and 3 different browsers, to the same result.

Obviously, this is causing problems when I'm trying to make changes to the backend and they have no effect because the database hasn't updated.

Does anybody know why this might be happening and how I get around this (or get it working)?



Forum Moderator, 1899 Posts

25 June 2011 at 10:17am

could try...


(find the index.php in the silverstripe download if you've deleted it)


Forum Moderator, 5523 Posts

25 June 2011 at 2:17pm

What is the URL of the page you have when you're on the home page? And like swaiba said, if you haven't got mod_rewrite then you have to prefix index.php