Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Suddenly broken site (PLESK)

Go to End

12 Posts   4051 Views


Community Member, 59 Posts

16 July 2011 at 12:25am

I just cleared out silverstripe-cache folder, made sure it was chmod 777, and tried the site again.
It has written two files in there - manifest-index and manifest-main
and then stopped with the fatal debug not found error in the log

A bit weird that it does this on a fresh install !

thanks for your help!



Community Member, 59 Posts

16 July 2011 at 12:28am

thanks - tried it both live and dev and no go .......


Forum Moderator, 1391 Posts

16 July 2011 at 1:30am

Edited: 16/07/2011 1:38am

Hi again,

Seems I spoke too soon - and didn't read too well: The error message states that you have access to your root folder and to /tmp/ as well. So my interpretation of your error message was off I guess- sorry for that :-(

But it seems that there definitely are issues with open_basedir and plesk. I found this, and there is more (no, there is nothing missing from the url):

[EDIT] OK - that's old, but,

So maybe your ISP does have the answers...


Community Member, 59 Posts

18 July 2011 at 4:20am


It was indeed the open_basedir settings changed in plesk- it had suddenly acquired a final slash.
But when SS calculates it's BASE_PATH it doesn't have the last slash (on 2.4.5) and so fails the "in path" test and thus fails to build the manifest properly and stops with fatal errors.

Just had to make a tweak to Core.php to add a final slash and suddenly all the errors went away and I was back up!

Thanks guys for the ideas and moral support - invaluable !!!!


Go to Top