Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

dev/build no longer working

Go to End

4 Posts   1351 Views


Community Member, 110 Posts

22 July 2011 at 3:57am


So I can navigate the front end of the website and the admin area. I haven't tried changing anything in the admin area. But when I run dev/build it doesn't work properly.

It starts to build and then begins to output some generic html:

Table SiteTree_versions: renamed from lowercase

<!-- where the generic html starts -->
Your Site Name

your tagline here

About Us
Contact Us
Server error

Sorry, there was a problem with handling your request.

<!-- end generic html -->

This was working fine prior to switching internet connections. To give a little background I was coding urls using localhost:8888 ...I then changed localhost to an ip addresss so I could cross browser test from a pc. Since my new internet connection has a new ip, I changed instances of the ip back to localhost. I can click through my site but dev/build will not complete.

Any suggestions on where the problem might be, would be helpful.



Community Member, 110 Posts

22 July 2011 at 4:20am

Just for reference I re-ran the build a few times (with ?flush=1 of course). I then cleared my browser cache and ran it a few more times. Each time it got a little further down the build. Finally it completed.

Even though I got it to complete that seems somewhat erroneous. Still interested to hear any thoughts on what might have caused this.



Forum Moderator, 5523 Posts

22 July 2011 at 8:11pm

The message in the output is the clue - "Server error

Sorry, there was a problem with handling your request." this is the 500 error page. Put your site into devmode and you can see the actual error message (could be related to memory..


Community Member, 110 Posts

23 July 2011 at 12:14am

@Willr - Thanks for the info! That is very help. A memory issue seems like a possible cause. I'll use the dev mode if it happens again. thanks!