Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SOLVED: Admin unaccessible: Fatal error Memory exhausted

Go to End

19 Posts   3931 Views


Community Member, 30 Posts

22 November 2011 at 11:04am

I filed a bug report and it hasn't been solved yet so there is no real fix. Just be careful when moving pages around in the backend (always save pages after moving). It has nothing to do with broken links. Just a circular reference because pages get confused who is whos parent page. To fix it reset the ParentID directly in the Database Table as explained in my previous post. If it's not clear enough ask again but try to be more specific what part is not clear :-)


Community Member, 16 Posts

22 November 2011 at 11:11am

Thanks for your reply. I am having the memory issue when trying to view the admin page.

how do I identify the entries in the 2 tables, whose ParentID need to be changed ?


Community Member, 30 Posts

22 November 2011 at 9:33pm

Having a memory issue could have many different causes. There is no reason to suspect it is what had happened to us. We found out that a content editor had moved pages around and that's how we found the problem. Therefore we knew which pages could be causing problems.

In your case if you are not aware of having moved pages around then
a) Put all pages to ParentID = 0 (Root) and then re-organize the whole tree (only makes sense if you have few pages)
b) Look through your SiteTree and SiteTree_Live tables and check if there is anything weird/inconsistent in the ParentIDs

Again: you could be facing a completely different issue than this problem.

Go to Top