Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SOLVED: Admin unaccessible: Fatal error Memory exhausted

Go to End

19 Posts   3890 Views


Forum Moderator, 1899 Posts

27 July 2011 at 2:42am

Well done for finding it... sounds like one for :)


Community Member, 30 Posts

27 July 2011 at 2:54am


Community Member, 121 Posts

11 August 2011 at 6:09am

Hi Willr

I'm having some massive memory leak problems. When you say large dateobjectsets are we talking about 100, 1000, 100 000 . I'm not sure if the size of my site is causing a problem or the code. We have a lot of many to many relations with fairly large groups in the 100-1000 range and that doesn't seem excessive so I was planning on combing over my code and setting up php debugging software like you suggested but wanted to check with you first whether these are reasonable numbers.



ps any more news as to when 3.0 will be available? thanks again


Forum Moderator, 5523 Posts

11 August 2011 at 8:53pm

vancouverWill I saw a leak of about 2k per data object (this was for research done for 2.3). I recommend installing XHProf and doing some research of your own!

ps any more news as to when 3.0 will be available? thanks again

At the moment the goal is still end of the year for another release (likely to be a final stage beta or rc)


Forum Moderator, 1899 Posts

11 August 2011 at 8:58pm

Also remember with memory issues there is no garbage collection by default... I've added this during large dataobject manipulations to reclaim the memory and avoid the dread memory exhausted error...


Community Member, 2 Posts

15 November 2011 at 3:07pm

I am now facing this problem and it really looks like what is happening as explained in this thread. I was doing some reorganizing of the pages and this came up!

I have tried upgrading to 2.4.6 but does not work. Is it something I need to change from the DB or some rebuilding of DB task I need to execute?

Please help as this is on my production. I can't edit the pages now.

Thanks in advance!


Community Member, 30 Posts

15 November 2011 at 9:15pm

Just log in to your Database (phpmyadmin etc.) and edit the tables SiteTree and SiteTree_Live. Change the ParentID of the broken pages. For simplicity just change it to 0 (Root) and then move them around in the backend when you're done. You should be able to find the page you're looking for in the DB by looking at the URLSegment (same DB Table).


Community Member, 16 Posts

22 November 2011 at 10:52am

Can you explain the fix in detail ?

The problem is due to broken pages ? We have 20+ blogs and both the tables SiteTree_Live and SiteTree do not have any entries with HasBrokenLink = 1.