Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Assets folder problem with SS 2.4.5 running on plesk


Go to End


11 Posts   2120 Views

Avatar
Stephan

Community Member, 55 Posts

11 August 2011 at 2:52am

Edited: 11/08/2011 2:55am

Hi experts,
I have a fresh installation of SS 2.4.5 on a virtual machine with Plesk.
Everything works fine, but I can't create a folder in the assets area.
I can upload files to the upload folder, but I can't create a new folder.
I get an error regarding mkdir.
What can I do?

TIA Stephan

Avatar
martimiz

Forum Moderator, 1391 Posts

12 August 2011 at 1:46am


If you've made sure that your /assets/ directory has sufficient rights, then this might be due to an issue in (a new version of) Plesk, where the php safemode and open_basedir are a bit too restrictive. If you are ons shared hosting, you might want to contact your hosting provider about that...

Avatar
Stephan

Community Member, 55 Posts

13 August 2011 at 3:31am

the rights are 777.
safe-Mode is switched off
and my vhost.conf says: php_admin_value open_basedir none

But still it is not working :(

Avatar
martimiz

Forum Moderator, 1391 Posts

13 August 2011 at 4:29am

what does the error say?

Avatar
Stephan

Community Member, 55 Posts

13 August 2011 at 5:39am

It says "Error creating folder"
And if i look at the firebug console it says "error at mkdir"

Avatar
martimiz

Forum Moderator, 1391 Posts

13 August 2011 at 5:57am

that's not much to go by... this is while your site's in dev mode?

Avatar
Stephan

Community Member, 55 Posts

13 August 2011 at 6:06am

Yes its in dev Mode

But the funny thing is, that I can upload images into the upload folder.
But I can't create a folder in the upload folder.

Avatar
Stephan

Community Member, 55 Posts

15 August 2011 at 8:57pm

Edited: 15/08/2011 8:59pm

Here is the detailed error message:

ERROR [Warning]: mkdir() [<a href='function.mkdir'>function.mkdir</a>]: Unable to access /var/www/vhosts/xxxx/httpdocs/assets/Uploads/Neuer-Ordner/
IN POST /admin/assets/addfolder
Line 595 in /var/www/vhosts/xxxxx/httpdocs/cms/code/AssetAdmin.php

I believe that this is an important issue as there are many virtual servers out there running with plesk.

Go to Top