Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Can't access CMS page

Go to End

2 Posts   1018 Views


Community Member, 6 Posts

15 August 2011 at 10:22am

Hi folks,

I've been happily building my site on my local machine but today when I tried to start it up, I can login and see the draft and published sites by clicking on the links in the bottom left corner but if I click on the CMS link, I get an error written on a properly themed web page > Sorry, there was an error handling your request. And in the browser address bar is > http://localhost/silverstripe/admin/show/1

I've tried dev/build?flush=1 and also just ?flush=1 and thinking it was just a problem with the CMS, I tried replacing the cms folder in root with a fresh copy and also the sapphire folder but doing that didn't change anything. I think the problem is related to a module I added, played around with and then removed. I also went into the database and removed some entries that were still there relating to that removed module.

Clicking on the published and draft site links shows slightly different pages. The published site has an extra navigation link across the top which is the module I removed. If I click on it, it shows a white screen with this >

SilverStripe diary module installed successfully, you can start writing your diary now.

Generated with the default template

Any help about how I can get back into the CMS admin page would be much appreciated.


Community Member, 6 Posts

15 August 2011 at 10:21pm


It seems the database is the problem. The entries I manually deleted from the database that were related to the module I deleted have rendered the database unusable. I thought those entries wouldn't have had any impact considering I had already deleted the module. Anyway, I installed a new instance of Silverstripe using the same database and I get the same errors. Then I created a new database for it and it's fine. Looks like I have to start over. Oh well, lesson learned.