Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

How to turn ON mod_rewrite in MS4W


Go to End


2 Posts   1298 Views

Avatar
sypou

Community Member, 10 Posts

5 October 2011 at 12:21am

Dear all,

How to turn ON mod_rewrite? I'm on localhost

I use MS4W
PHP Version 5.3.5
Apache/2.2.17
DOCUMENT_ROOT C:/ms4w/Apache/htdocs

What I did is I removed the comment in:

C:\ms4w\Apache\conf\httpd.conf

...
#LoadModule reqtimeout_module modules/mod_reqtimeout.so
LoadModule rewrite_module modules/mod_rewrite.so
LoadModule setenvif_module modules/mod_setenvif.so
#LoadModule speling_module modules/mod_speling.so
...

but still, when I install SilverStripe, I get

Webserver Configuration All Requirements Pass but 1 Warning
URL rewriting support You need mod_rewrite to use friendly URLs with SilverStripe, but it is not enabled.

Any idea?

Serge

Avatar
sypou

Community Member, 10 Posts

5 October 2011 at 2:18am

Again... I got it.

I was right with the configuration but I had to change the AllowOverride None to AllowOverride All in the Options Indexes FollowSymLinks.
Then I did a fresh install of SilverStripe.

Thank you anyway...

Serge