Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

SOLVED: Possible causes for Unpublish buttons to disappear

Go to End



Community Member, 66 Posts

26 October 2011 at 10:00am

Edited: 14/11/2011 9:20am

EDIT: This was a lucky find. I'd made an IsNew() method for that page type to determine if the ArticlePages are recent. Turns out an isNew() method is used in SiteTree's isPublished() method and my custom one was overriding it. Yay!!!


I am having a section of articles managed by other people. Until recently, everything was working alright. I've worked for a few days and today I noticed that the articles do not have an Unpublish button anymore, only "Delete from Draft site". If the button is pressed, the articles remain live. The only thing left to do in this case is to go to the SiteTree and use a Batch option of Delete from Live site. I ran a few SiteTree cleanup scripts (remove orphans), but I am guessing if there was damage done to the SiteTree tables other page types wouldn't have Unpublish as well.

I will be having unskilled people working with this so this is quite crucial.

Are there any common causes for the Unpublish button to disappear? I have all my permissions set. I'm really really stuck with this, please help!

PS I also noticed Unpublish doesn't actually unpublish ANY page...