Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Can't add administrators

Go to End

7 Posts   1103 Views


Community Member, 6 Posts

18 February 2012 at 4:02am

I can add people just fine to the security group, but when I try to add them as administrators or anything else I just get an error.
Wish I could be more specific about the error but it is just blank, and it happens in all browsers I have tried.

Everything else has worked just fine so it sucks to have an issue like this so close to finishing.

What is the sql command to add administrators? So I can add them in manually until the cms is fixed.


Community Member, 6 Posts

19 February 2012 at 1:58pm

Edited: 19/02/2012 1:59pm

Ok hmm, got part of it to work. After just bashing the button to add someone to the "Content Authors" group, one slipped in and now it seems like that group works fine. But not the administrator group... And it still seems a bit sketchy.

Not an huge issue right now I guess since I can just edit the Group_Members sql table to move people to the administrator group. But this way is a bit annoying for many reasons.


Forum Moderator, 1391 Posts

21 February 2012 at 12:23am

Hi Kittybeard,

Have you tried temporarily setting the CMS to dev mode? That might get you a more elaborate errormessage: in your _config.php:


Or use the Firebug extension in Firefox to see if there is an error there?


Community Member, 6 Posts

21 February 2012 at 1:44am

Edited: 28/02/2012 12:08am

The debugging environment didn't help, but after some experimentation in firebug I got something:

POST http://**.com/ground/admin/security/Edit...ers&action_callfieldmethod&methodName=addtogroup 406 Not Acceptable 378ms

"NetworkError: 406 Not Acceptable - http://**.com/ground/admin/security/EditForm?fieldName=Members&action_callfieldmethod&methodName=addtogroup"

No idea what would cause this, specially since everything else works without an issue.


Forum Moderator, 1391 Posts

21 February 2012 at 2:33am

Edited: 21/02/2012 2:38am

I've never seen this myself, but some googling learned that this might have something to do with mod_security (an optional Apache firewall-ish module) being enabled on the webserver, finding something amiss with the page, possibly with the posted data. Other CMSses seem to run into this problem as well.

If that's the case, the general advice is to ask the host to do something about it (loosen the rules), or disable it. I found this bit of code, to put into your .htaccess:

# Turn off mod_security filtering.
<IfModule mod_security.c>
SecFilterEngine Off
SecFilterScanPOST Off

[EDIT] I don't really know if this would be the right way to go, security-wise, but maybe it at least hints in the right direction


Community Member, 6 Posts

21 February 2012 at 9:37am

Thank you so much for all the work finding what was wrong :). Will have to see if I can create an .htaccess or if I will have to ask them. Although I don't really want to lessen the security... oh well, will have to see what will be done.


Community Member, 2 Posts

11 February 2013 at 4:25am

Kittybeard .. did you ever solve this? The solution martimiz suggested did not work at all for me.