Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Security & userforms give error on live server

Go to End

3 Posts   753 Views


Community Member, 9 Posts

29 February 2012 at 9:21am

Recently I moved a website to Silverstripe for a client. Unfortunately there seems to be a problem on the server and I can't figure out what it is. On my local server (at home and at work) the site works just fine. But on the live server (not one of our own) I can't create form fields (using the userforms module) or email recipients and I can't add a member via the CMS. Just editing the database works, but off-course thats not the solution.

Silverstripe gives me an error saying the page doesn't exist, and trying to get to the Administrator group in Security gives me the source code of the error page. Setting the site to dev mode doesn't give me better error messages but just the same ones. I also tried copying the database to the local server to see if there maybe is something wrong with that, but again everything works fine on the local server.

The only thing I can think of is that there is something wrong with the live server. I know the provider uses /admin/ for there own admin login, but they changed that for me to /adm/.

Has anybody else encountered this problem before and maybe know a solution? I don't know what to look for anymore.


Forum Moderator, 5523 Posts

29 February 2012 at 9:33pm

Setting the site to dev mode doesn't give me better error messages but just the same ones

What is the error message, you may need to look in your PHP error log as production servers should have display_errors turned off. If you're getting 404 then it'll probably be an issue about your hosting base rewrite / redirections not supported by SilverStripe.


Community Member, 9 Posts

1 March 2012 at 12:07am

Thanks for your quick reply. It turned out the problem was in the php.ini file. It needed cgi.fix_pathinfo=0 and now the problem is resolved.