Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

[solved] Images not resampling--not showing up in _resampled

Go to End

3 Posts   2206 Views


Community Member, 130 Posts

30 March 2012 at 5:54pm

SS 2.4.7 on Linux server

Currently I have a perfectly working installation of SS that I'm trying to migrate to a live server. But when I upload an image through the CMS on the new server it's not resampling the images.

What I've done:

1. I have tar.gz'd the dev server files and untarred them on the new server.

2. Imported the db dump to the new db

3. Changed my connection vars in _config.php

4. Set group ownership recursively on the assets folder to 'apache' (chown -R root:apache assets)

Now, when I upload a photo through the CMS it will upload the picture, and I can see the picture on the live page, but it does not resample the pic and the thumbnail will not show up in the CMS.

Can someone shove me in the right direction of permissions? Assuming I'm having a permissions problem.

Attached is a pic showing the permissions of the pic I tried to upload (origamibox1.jpg) and the permissions of the _resampled directory. The photo does not get resampled and does not appear in the _resampled directlty.

Any help is greatly appreciated.


Attached Files

Community Member, 130 Posts

31 March 2012 at 3:45am

GD libs were munged! Problem fixed.


Community Member, 78 Posts

8 June 2014 at 3:59pm

Edited: 10/07/2014 8:30pm


Can you advice how to fix this.